What's needed to use Preloadr

All you need to use this service is a valid Flickr account and a compatible browser. There's no separate registration required, you will be redirected to Flickr for login. If you don't have a Flickr account, sign up for one first, it's easy.

Supported browsers

To take advantage of all features, we recommend to use the latest version of the browser of your choice. Preloadr has been tested with the following products (minimum version):

  • Mozilla Firefox (1.0)
  • Apple Safari (1.2)
  • Opera (8)
  • Internet Explorer (5.5)

A broadband internet connection is recommended.

Back to home